Server Requirements for Job Script

JobScript Server Requirements

To run our Job Listing Script, servers are required to have the following setup:

  • Apache web server with mod_rewrite enabled.
  • MySQL version 4.0+
  • GD Library 2+ with freetype support.
  • PHP 5.2+ with the following configuration
    1. safe_mode = off
    2. open_basedir = (no value)
    3. output_buffering = on
    4. register_argc_argv = On
    5. max_execution_time = 1000 (Recommended or higher)
    6. session.gc_maxlifetime = 15000 (Recommended or higher)
    7. upload_max_filesize = 25M (Recommended or higher)
    8. post_max_size = 25M (Recommended or higher)
    9. register_globals = off
    10. PECL json >= 1.2.0
    11. short_open_tag = on
    12. allow_url_fopen = on
    13. strict standards off (~E_STRICT)
  • Apache MultiViews disabled
  • Ability to run a cron job once per hour
  • Ability to run PHP from the command line (CLI) with exec()
  • Ability to execute background processes with exec("binary > /dev/null &")
  • Google Maps API Key - For Google Location Autocomplete


Need Hosting For JobScript?

View Job Listing Script Recommended Web Hosts